summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 6acc869..1a2b918 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,8 @@
# You should have received a copy of the GNU General Public License
# along with opkbuild. If not, see <http://www.gnu.org/licenses/>.
+KEY='2250 31F0 47FF E516 63ED 516F 1A45 9ECD E4D6 04BE'
+
if IN_GIT
PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^[^/-]*[/-]||')
else
@@ -140,11 +142,14 @@ release:
md5sum $(DIST_ARCHIVES) >MD5SUMS
sha256sum $(DIST_ARCHIVES) >SHA256SUMS
set -e; \
+ sigs=''; \
for f in $(DIST_ARCHIVES); do \
- gpg --armor --sign $${f}; \
- done
- ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE)
- rsync -az --progress --stats $(DIST_ARCHIVES) MD5SUMS SHA256SUMS \
+ gpg --local-user $(KEY) --armor --sign $${f}; \
+ sigs="$${sigs} $${f}.asc"; \
+ done; \
+ ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE); \
+ rsync -az --progress --stats $(DIST_ARCHIVES) $${sigs} \
+ MD5SUMS SHA256SUMS \
files@files.proteanos.com:files/pub/$(PACKAGE)/$(VERSION)/
'$(srcdir)/scripts/announce-release.sh' \
$(PACKAGE) $(VERSION) '$(PACKAGE_NAME)'