summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 2 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index f7f6fe1..9faf35f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,7 @@
# You should have received a copy of the GNU General Public License
# along with opkbuild. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([opkbuild], [4.0.0],
+AC_INIT([opkbuild], [4.0.0+dev],
[mailto:proteanos-dev@lists.proteanos.com], [opkbuild],
[http://www.proteanos.com/dev/opkbuild/])
AC_SUBST([PACKAGE_DESCRIPTION], ['opkbuild'])
@@ -59,31 +59,6 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
- [make],
- [AS_HELP_STRING([--with-make=PATH], [path to make utility])],
- [
- case "${withval}" in
- 'yes'|'')
- AC_MSG_ERROR([--with-make requires an argument])
- ;;
- 'no')
- AC_MSG_ERROR([make is required])
- ;;
- *)
- MAKE="${withval}"
- AC_SUBST([MAKE])
- ;;
- esac
- ],
- [
- AC_PATH_PROG([MAKE], [make])
- if test -z "${MAKE}"; then
- AC_MSG_ERROR([make not found])
- fi
- ]
-)
-
-AC_ARG_WITH(
[opkg],
[AS_HELP_STRING([--with-opkg=PATH], [path to opkg utility])],
[
@@ -111,7 +86,7 @@ AC_ARG_WITH(
AC_ARG_WITH(
[metadata],
[AS_HELP_STRING([--with-metadata=SYSTEM],
- [use SYSTEM metadata plugin \[default: proteanos\]])],
+ [use SYSTEM metadata plugin @<:@default: proteanos@:>@])],
[
case "${withval}" in
'yes'|'')