summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ed85905..c11fd2a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,8 +96,20 @@ uninstall-local:
dir="$(DESTDIR)$(localedir)/$${ff%.ms}/LC_MESSAGES"; \
rm -f "$${dir}/$(textdomain).ms"; \
done
+ for f in $(archtab_sources); do \
+ ff="$${f#*/}"; \
+ dir="$(DESTDIR)$(archtabdir)/$${ff%/?*}"; \
+ rm -f "$${dir}/$${ff#*/}"; \
+ done
uninstall-hook:
+ for f in $(archtab_sources); do \
+ ff="$${f#*/}"; \
+ dir="$(DESTDIR)$(archtabdir)/$${ff%/?*}"; \
+ if [ -d "$${dir}" ]; then \
+ rmdir "$${dir}" || exit 1; \
+ fi; \
+ done
for dir in \
'$(DESTDIR)$(pkgdatabuildsystemdir)' \
'$(DESTDIR)$(archtabdir)' \