summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2013-10-22 12:46:58 (EDT)
committer P. J. McDermott <pjm@nac.net>2013-10-22 12:46:58 (EDT)
commitdcfc46ea2334636c9c4dee677e975e1cb96920de (patch)
tree5c68f1334f3c6168f782efedeec6b0f898524f34 /configure.ac
Set up build system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 51 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5d71b7c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,51 @@
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright (C) 2013 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_INIT([ProKit], [0.1.0], [mailto:proteanos-dev@lists.proteanos.com], [prokit],
+ [http://www.proteanos.com/dev/prokit/])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_SRCDIR([src/prokit.sh])
+
+AM_INIT_AUTOMAKE([gnu check-news dist-bzip2 dist-xz subdir-objects])
+
+AC_ARG_WITH(
+ [sh],
+ [AS_HELP_STRING([--with-sh], [POSIX-conformant shell with ``local''])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-sh requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sh is required])
+ ;;
+ *)
+ SH="${withval}"
+ AC_SUBST([SH])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SH], [sh])
+ if test -z "${SH}"; then
+ AC_MSG_ERROR([sh not found])
+ fi
+ ]
+)
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT()