summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorpixdamix <pixdamix@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2009-11-05 03:46:33 (EST)
committer pixdamix <pixdamix@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2009-11-05 03:46:33 (EST)
commit00d9ca3aaa56c083cfbb051235f3bdcbe6c8c253 (patch)
tree35f945f01329ccb860f33f81a494eb17c9eed549 /configure.ac
parentaf66c658642635a3c951bb0ee130e40e7f084fd9 (diff)
Add pathfinder support for certificate validation
From http://code.google.com/p/pathfinder-pki/ PathFinder is designed to provide a mechanism for any program to perform RFC3280-compliant path validation of X509 certificates, even when some of the intermediate certificates are not present on the local machine. By design, Pathfinder automatically downloads any such certificates from the Internet as needed using the AIA and CRL distribution point extensions of the certificates it is processing. It has the ability to do revocation status checking either using CRL or OCSP, or both. And, given the recent vulnerabilities that have rendered the MD5 algorithm highly suspect, it allows the administrator to choose to not validate certificates using that algorithm anywhere in the trust path. git-svn-id: http://opkg.googlecode.com/svn/trunk@261 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 95233b5..df58817 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,22 @@ AC_PROG_LIBTOOL
# Checks for libraries
+dnl extra argument: --with-pathfinder
+AC_ARG_ENABLE(pathfinder,
+ AC_HELP_STRING([--with-pathfinder], [With libpathfinder support.
+ [[default=no]] ]),
+ [want_pathfinder="$enableval"], [want_pathfinder="no"])
+dnl Check for libpathfinder
+if test "x$want_pathfinder" = "xyes"; then
+ PKG_CHECK_MODULES([PATHFINDER], [pathfinder-openssl dbus-1 openssl])
+ if test -n "$PATHFINDER_CFLAGS$PATHFINDER_LIBS"; then
+ AC_DEFINE(HAVE_PATHFINDER, 1, [we have pathfinder])
+ fi
+ AC_SUBST(PATHFINDER_CFLAGS)
+ AC_SUBST(PATHFINDER_LIBS)
+fi
+AM_CONDITIONAL(HAVE_PATHFINDER, test "x$want_pathfinder" = "xyes")
+
# check for libcurl
AC_ARG_ENABLE(curl,
AC_HELP_STRING([--enable-curl], [Enable downloading with curl
@@ -36,7 +52,7 @@ AC_ARG_ENABLE(curl,
[want_curl="$enableval"], [want_curl="yes"])
if test "x$want_curl" = "xyes"; then
- PKG_CHECK_MODULES(CURL, libcurl)
+ PKG_CHECK_MODULES(CURL, [libcurl])
AC_DEFINE(HAVE_CURL, 1, [Define if you want CURL support])
fi
@@ -65,7 +81,7 @@ fi
# check for libssl-curl
AC_ARG_ENABLE(ssl-curl,
AC_HELP_STRING([--enable-ssl-curl], [Enable certificate authentication with curl
- [[default="$default_sslcurl"]] ]),
+ [[default="yes"]] ]),
[want_sslcurl="$enableval"], [want_sslcurl="yes"])
if test "x$want_curl" = "xyes" -a "x$want_sslcurl" = "xyes"; then