summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-14 23:19:50 (EST)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-14 23:19:50 (EST)
commit44d7bd09843dbc56f3799326553ad1c18f1ec501 (patch)
treed235dfcc57b2a9bdf109a7b858ce7b5e6b0adf40 /configure.ac
parentb67dc062ae9c689f0453d46bba47ceba832f676f (diff)
opkg: add configure check for libgpgme
git-svn-id: http://opkg.googlecode.com/svn/trunk@19 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 48 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a076742..2048313 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,9 +19,56 @@ AC_PROG_LN_S
AM_PROG_INSTALL_STRIP
AC_PROG_LIBTOOL
-# Checks for libraries (hah! opkg is pretty much self-contained)
+# Checks for libraries
+
+# check for libcurl
PKG_CHECK_MODULES(CURL, libcurl)
+
+
+dnl **********
+dnl GPGME
+dnl **********
+
+ok="no"
+min_gpgme_version=1.0.0
+AC_PATH_PROG(GPGME_CONFIG, gpgme-config, "failed")
+if test $GPGME_CONFIG != "failed" ; then
+ AC_MSG_CHECKING(for GPGME - version >= $min_gpgme_version)
+ req_major=`echo $min_gpgme_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
+ req_minor=`echo $min_gpgme_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
+ req_micro=`echo $min_gpgme_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
+ gpgme_config_version=`$GPGME_CONFIG --version`
+ major=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
+ minor=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+ if test "$major" -eq "$req_major"; then
+ if test "$minor" -ge "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
+ fi
+ fi
+fi
+
+if test $ok = "yes"; then
+ GPGME_CFLAGS=`$GPGME_CONFIG --cflags`
+ GPGME_LIBS=`$GPGME_CONFIG --libs`
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_ERROR(GPGME $min_gpgme_version or later needed)
+fi
+
+
+
+
# Checks for header files
AC_HEADER_DIRENT
AC_HEADER_STDC