summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2009-06-14 01:43:35 (EDT)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2009-06-14 01:43:35 (EDT)
commita2f5f54adba4fa703f11f4d94756911db83ed2a4 (patch)
tree296a2c26eb997fcd6b5c706d5b81844c995499e5 /configure.ac
parent10f0dceaf9ed1dea7c2ed7d41e7a748d34dd9324 (diff)
adds a configure option so "/etc/opkg" can be
changed when opkg is configured and built. fix issue due to an error of opkg_conf.c Thanks to jlc <jlcster@gmail.com> http://groups.google.com/group/opkg-devel/browse_thread/thread/5c6e55832a7168aa git-svn-id: http://opkg.googlecode.com/svn/trunk@213 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 315e139..4346373 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,8 +127,9 @@ opkglibdir=
AC_ARG_WITH(opkglibdir,
[ --with-opkglibdir=DIR specifies directory to put status and info files.
"/opkg" is always added so if you want your files
- to be in /usr/lib/opkg you should indicate
- --with-opkglibdir=/usr/lib ],
+ to be in /var/lib/opkg instead of /usr/lib/opkg
+ you should indicate
+ --with-opkglibdir=/var/lib ],
[case "${withval}" in
yes) AC_MSG_ERROR(bad value ${withval} given for opkg libs directories ) ;;
no) ;;
@@ -140,7 +141,27 @@ if test x$opkglibdir = x; then
opkglibdir=/usr/lib
fi
+ipkgetcdir=
+AC_ARG_WITH(opkgetcdir,
+[ --with-ipkgetcdir=DIR specifies directory for opkg.conf file,
+ "/opkg" is always added so if you want your files
+ to be in /usr/etc/opkg instead of /etc/opkg
+ you should indicate
+ --with-ipkgetcdir=/usr/etc ],
+[case "${withval}" in
+yes) AC_MSG_ERROR(bad value ${withval} given for opkg.conf directory ) ;;
+no) ;;
+*) opkgetcdir=$with_opkgetcdir ;;
+esac])
+
+# Default local prefix if it is empty
+if test x$opkgetcdir = x; then
+ opkgetcdir=/etc
+fi
+
+
AC_SUBST(opkglibdir)
+AC_SUBST(opkgetcdir)
AC_OUTPUT(
Makefile