summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorpixdamix <pixdamix@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2009-11-24 03:04:39 (EST)
committer pixdamix <pixdamix@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2009-11-24 03:04:39 (EST)
commitbf29bd974b428e00d7f614b082125f922c808486 (patch)
tree67e2863a1086e437ce72c8a3ca5e7e253f22acc4 /configure.ac
parent3d2102ff6d5f71acf929a55d1fb139fa71b7a306 (diff)
shave: making the autotools output sane
Use shave (http://git.lespiau.name/cgit/shave) to make compilation more human friendly. Shave is enabled by default, Use --disable-shave to see the actual compiler and linker commands being executed. git-svn-id: http://opkg.googlecode.com/svn/trunk@364 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f97a1c6..946162b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@ AC_INIT(libopkg/libopkg.c)
AC_CONFIG_AUX_DIR([conf])
AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_MACRO_DIR([shave])
AM_INIT_AUTOMAKE([opkg], [0.1.6])
AM_CONFIG_HEADER(libopkg/config.h)
@@ -10,6 +11,10 @@ AM_CONFIG_HEADER(libopkg/config.h)
AC_CANONICAL_HOST
AC_GNU_SOURCE
+# Disable C++/Fortran checks
+define([AC_LIBTOOL_LANG_CXX_CONFIG], [:])
+define([AC_LIBTOOL_LANG_F77_CONFIG], [:])
+
for top_builddir in . .. ../.. $ac_auxdir $ac_auxdir/..; do
test -f $top_builddir/configure && break
@@ -253,6 +258,9 @@ fi
AC_SUBST(opkglibdir)
AC_SUBST(opkgetcdir)
+# Setup output beautifier.
+SHAVE_INIT([shave], [enable])
+
AC_OUTPUT(
Makefile
libopkg/Makefile
@@ -262,4 +270,6 @@ AC_OUTPUT(
utils/Makefile
utils/update-alternatives
libopkg.pc
+ shave/shave
+ shave/shave-libtool
)