summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2014-07-04 13:21:24 (EDT)
committer P. J. McDermott <pj@pehjota.net>2014-07-05 22:02:50 (EDT)
commitc2c4e310f507a77a3f381a70bf51d6c638061c41 (patch)
tree7a0846f0015b2c033af4f3eb55b2506cf2a1193e /configure.ac
parent1e523fd5a8611f810028f26057f1981acfca8262 (diff)
configure.ac: Add --enable-multiarch option
Signed-off-by: P. J. McDermott <pj@pehjota.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3a9e4bc..24c450b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,6 +173,16 @@ fi
AC_SUBST(GPGME_CFLAGS)
AC_SUBST(GPGME_LIBS)
+# check for multiarch
+AC_ARG_ENABLE(multiarch,
+ AC_HELP_STRING([--enable-multiarch], [Enable multiarch
+ [[default=no]] ]),
+ [want_multiarch="$enableval"], [want_multiarch="no"])
+
+if test "x$want_multiarch" = "xyes"; then
+ AC_DEFINE(HAVE_MULTIARCH, 1, [Define if you want multiarch support])
+fi
+
# Checks for header files
AC_HEADER_DIRENT