summaryrefslogtreecommitdiffstats
path: root/libbb/Makefile.am
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-14 23:10:56 (EST)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-14 23:10:56 (EST)
commit8bf49d16a637cca0cd116450dfcabc4c941baf6c (patch)
treebea96583e7a63f1b87ad4ef07b191f121348fe78 /libbb/Makefile.am
parent4074befd4db12e78af74f7e1438459125b0b3016 (diff)
* Add ipkg for future development
git-svn-id: http://opkg.googlecode.com/svn/trunk@3 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'libbb/Makefile.am')
-rw-r--r--libbb/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/libbb/Makefile.am b/libbb/Makefile.am
new file mode 100644
index 0000000..1f2dd12
--- /dev/null
+++ b/libbb/Makefile.am
@@ -0,0 +1,30 @@
+HOST_CPU=@host_cpu@
+BUILD_CPU=@build_cpu@
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@
+
+noinst_LTLIBRARIES = libbb.la
+
+libbb_la_SOURCES = gz_open.c \
+ libbb.h \
+ unzip.c \
+ wfopen.c \
+ unarchive.c \
+ copy_file.c \
+ copy_file_chunk.c \
+ error_msg.c error_msg_and_die.c \
+ perror_msg.c perror_msg_and_die.c \
+ xreadlink.c \
+ concat_path_file.c \
+ ask_confirmation.c \
+ verror_msg.c vperror_msg.c \
+ xfuncs.c messages.c \
+ last_char_is.c \
+ make_directory.c \
+ safe_strncpy.c \
+ parse_mode.c \
+ time_string.c \
+ all_read.c \
+ mode_string.c
+
+libbb_la_CFLAGS = $(ALL_CFLAGS)
+#libbb_la_LDFLAGS = -static