summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
authorgraham.gower@gmail.com <graham.gower@gmail.com@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2011-05-25 20:51:50 (EDT)
committer graham.gower@gmail.com <graham.gower@gmail.com@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2011-05-25 20:51:50 (EDT)
commit1e0e1f2f283ffdedb1c0d05c8e572074acf6baa8 (patch)
tree3042bc145819a5d3340a40130f95bffe806dca2e /libopkg/Makefile.am
parent82779432519ebc597fc7b74b4e6313fabd3cb9e0 (diff)
Improve the opkg_{get,set}_option() C API.
This breaks compatibility with the previous API, so bump the lib version. git-svn-id: http://opkg.googlecode.com/svn/trunk@622 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
index 373d09c..043c5c4 100644
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -46,6 +46,8 @@ libopkg_la_SOURCES = \
libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS) $(OPENSSL_LIBS) $(PATHFINDER_LIBS)
+libopkg_la_LDFLAGS = -version-info 1:0:0
+
# make sure we only export symbols that are for public use
#libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"