summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-14 23:25:08 (EST)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-14 23:25:08 (EST)
commit4b0b7ca249bfa4ecc099c2ca56527eb91776f198 (patch)
treedb5d2602d75a69cc9e1f7f30cbac584f0ab45c45 /libopkg/Makefile.am
parent868cbd739052719d5e0580a0fda6101dada1ce1e (diff)
opkg: re-arrange source code into sub-directories
git-svn-id: http://opkg.googlecode.com/svn/trunk@33 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
new file mode 100644
index 0000000..ad4de4d
--- /dev/null
+++ b/libopkg/Makefile.am
@@ -0,0 +1,76 @@
+
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_builddir)
+
+libopkg_includedir=$(includedir)/libopkg
+
+libopkg_include_HEADERS= \
+ args.h \
+ conffile.h \
+ conffile_list.h \
+ config.h \
+ hash_table.h \
+ includes.h \
+ opkg_conf.h \
+ opkg.h \
+ opkg_message.h \
+ opkg_state.h \
+ nv_pair.h \
+ nv_pair_list.h \
+ pkg_depends.h \
+ pkg_dest.h \
+ pkg_dest_list.h \
+ pkg.h \
+ pkg_hash.h \
+ pkg_src.h \
+ pkg_src_list.h \
+ pkg_vec.h \
+ str_list.h \
+ void_list.h \
+ libopkg.h
+
+libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
+
+opkg_core_sources = args.c args.h opkg.c \
+ user.c user.h
+opkg_libcore_sources = args.c args.h libopkg.c libopkg.h opkg.h\
+ user.c user.h opkg_state.c opkg_state.h
+opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
+ opkg_configure.c opkg_configure.h \
+ opkg_download.c opkg_download.h \
+ opkg_install.c opkg_install.h \
+ opkg_upgrade.c opkg_upgrade.h \
+ opkg_remove.c opkg_remove.h
+opkg_db_sources = opkg_conf.c opkg_conf.h \
+ opkg_utils.c opkg_utils.h pkg.c pkg.h hash_table.h \
+ pkg_depends.c pkg_depends.h pkg_extract.c pkg_extract.h \
+ hash_table.c pkg_hash.c pkg_hash.h pkg_parse.c pkg_parse.h \
+ pkg_vec.c pkg_vec.h
+opkg_list_sources = conffile.c conffile.h conffile_list.c conffile_list.h \
+ nv_pair.c nv_pair.h nv_pair_list.c nv_pair_list.h \
+ pkg_dest.c pkg_dest.h pkg_dest_list.c pkg_dest_list.h \
+ pkg_src.c pkg_src.h pkg_src_list.c pkg_src_list.h \
+ str_list.c str_list.h void_list.c void_list.h
+opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c md5.h \
+ sprintf_alloc.c sprintf_alloc.h str_util.c str_util.h \
+ xregex.c xregex.h xsystem.c xsystem.h
+
+libopkg_la_SOURCES = \
+ $(opkg_libcore_sources) \
+ $(opkg_cmd_sources) $(opkg_db_sources) \
+ $(opkg_util_sources) $(opkg_list_sources)
+
+libopkg_la_CFLAGS = -DOPKG_LIB $(ALL_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+lib_LTLIBRARIES = libopkg.la
+
+
+noinst_PROGRAMS = opkg_hash_test opkg_extract_test
+
+opkg_hash_test_LDADD = $(top_builddir)/libbb/libbb.la
+opkg_hash_test_SOURCES = opkg_hash_test.c $(opkg_db_sources) $(opkg_util_sources) $(opkg_list_sources)
+opkg_hash_test_CFLAGS = $(ALL_CFLAGS)
+
+opkg_extract_test_LDADD = $(top_builddir)/libbb/libbb.la
+opkg_extract_test_SOURCES = opkg_extract_test.c $(opkg_db_sources) $(opkg_util_sources) $(opkg_list_sources)
+opkg_extract_test_CFLAGS = $(ALL_CFLAGS)
+
+