summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-15 00:07:12 (EST)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-15 00:07:12 (EST)
commit5b41fdceb43de4a2ada066b4fa685bce2ed34870 (patch)
treefcce8075cb71fad80eaa10c726bb105065d8b8d4 /libopkg/Makefile.am
parent3523443344809d2f357a5008931c9f79e91a3de3 (diff)
libopkg: stop exporting random symbols into the wild
git-svn-id: http://opkg.googlecode.com/svn/trunk@68 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
index e816317..f751195 100644
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -29,6 +29,9 @@ libopkg_include_HEADERS= \
libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
+# make sure we only export symbols that are for public use
+libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
+
opkg_core_sources = args.c args.h \
user.c user.h
opkg_libcore_sources = args.c args.h libopkg.c libopkg.h\