summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-15 00:13:49 (EST)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-15 00:13:49 (EST)
commit6af0e9c6eb022eb4372fa65070287e31f4873699 (patch)
tree6c552b86968d5a49bdc91d3236c4147ab3f68017 /libopkg/Makefile.am
parent6c77121fba6a9ca68e8a8ad39405542940999d15 (diff)
opkg: clean up libopkg Makefile.am a bit
git-svn-id: http://opkg.googlecode.com/svn/trunk@94 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
index 5e713dd..cb2eb7a 100644
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -1,14 +1,9 @@
-ALL_CFLAGS=-g -O -Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir)
+ALL_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir)
libopkg_includedir=$(includedir)/libopkg
-
libopkg_include_HEADERS= opkg.h
-libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
-
-# make sure we only export symbols that are for public use
-libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
opkg_core_sources = args.c args.h \
user.c user.h
@@ -35,12 +30,16 @@ opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c
sprintf_alloc.c sprintf_alloc.h str_util.c str_util.h \
xregex.c xregex.h xsystem.c xsystem.h
+lib_LTLIBRARIES = libopkg.la
libopkg_la_SOURCES = \
$(opkg_libcore_sources) \
$(opkg_cmd_sources) $(opkg_db_sources) \
$(opkg_util_sources) $(opkg_list_sources)
libopkg_la_CFLAGS = $(ALL_CFLAGS) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
-lib_LTLIBRARIES = libopkg.la
+libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
+# make sure we only export symbols that are for public use
+libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
+