summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-15 00:07:31 (EST)
committer ticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>2008-12-15 00:07:31 (EST)
commit8261c5aeb2e39f0bda4f30a53b34303f151a4da3 (patch)
tree5b7c9bfd61c56204ffffcf745960dd9baf5cfcd6 /libopkg/Makefile.am
parent0ff5e900eb30e2096418ae0e9bc8b7f6e80a8b8e (diff)
opkg: start new libopkg api in opkg.{c,h} and remove all other header files
from being copied to includes git-svn-id: http://opkg.googlecode.com/svn/trunk@70 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am27
1 files changed, 3 insertions, 24 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
index f751195..5e713dd 100644
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -3,29 +3,7 @@ ALL_CFLAGS=-g -O -Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_
libopkg_includedir=$(includedir)/libopkg
-libopkg_include_HEADERS= \
- args.h \
- conffile.h \
- conffile_list.h \
- config.h \
- hash_table.h \
- includes.h \
- opkg_conf.h \
- opkg_message.h \
- opkg_state.h \
- nv_pair.h \
- nv_pair_list.h \
- pkg_depends.h \
- pkg_dest.h \
- pkg_dest_list.h \
- pkg.h \
- pkg_hash.h \
- pkg_src.h \
- pkg_src_list.h \
- pkg_vec.h \
- str_list.h \
- void_list.h \
- libopkg.h
+libopkg_include_HEADERS= opkg.h
libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
@@ -35,7 +13,8 @@ libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
opkg_core_sources = args.c args.h \
user.c user.h
opkg_libcore_sources = args.c args.h libopkg.c libopkg.h\
- user.c user.h opkg_state.c opkg_state.h
+ user.c user.h opkg_state.c opkg_state.h \
+ opkg.c opkg.h
opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
opkg_configure.c opkg_configure.h \
opkg_download.c opkg_download.h \