summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2013-11-20 10:34:49 (EST)
committer Paul Barker <paul@paulbarker.me.uk>2013-12-17 16:00:35 (EST)
commit962ba1c6334d2f95137504f5353df9b6f2362465 (patch)
treeb5f81866e37fdc19bbf05a8964498daa05c2d51a /libopkg/Makefile.am
parent670879cbe91702c77da6494c2bc7102f5d014a0d (diff)
libopkg: Don't install opkg_pathfinder.h
opkg_pathfinder.h is an internal header and shouldn't be used by applications which link against libopkg. It is much simpler to make this decision and allow the header to check flags defined in config.h than to make it independent of config.h. Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Cc: Carsten Schoenert <c.schoenert@gmail.com>
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am43
1 files changed, 42 insertions, 1 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
index b6f4f7b..11772f1 100644
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -2,8 +2,49 @@
AM_CFLAGS=-Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DOPKGLOCKFILE=\"@opkglockfile@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
libopkg_includedir=$(includedir)/libopkg
-libopkg_include_HEADERS= *.h $(srcdir)/*.h
+# Headers to be installed: everything except opkg_pathfinder.h as that header
+# requires symbols from config.h
+libopkg_include_HEADERS = $(srcdir)/active_list.h \
+ $(srcdir)/cksum_list.h \
+ $(srcdir)/conffile.h \
+ $(srcdir)/conffile_list.h \
+ $(srcdir)/file_util.h \
+ $(srcdir)/hash_table.h \
+ $(srcdir)/list.h \
+ $(srcdir)/md5.h \
+ $(srcdir)/nv_pair.h \
+ $(srcdir)/nv_pair_list.h \
+ $(srcdir)/opkg.h \
+ $(srcdir)/opkg_cmd.h \
+ $(srcdir)/opkg_conf.h \
+ $(srcdir)/opkg_configure.h \
+ $(srcdir)/opkg_defines.h \
+ $(srcdir)/opkg_download.h \
+ $(srcdir)/opkg_install.h \
+ $(srcdir)/opkg_message.h \
+ $(srcdir)/opkg_remove.h \
+ $(srcdir)/opkg_upgrade.h \
+ $(srcdir)/opkg_utils.h \
+ $(srcdir)/parse_util.h \
+ $(srcdir)/pkg.h \
+ $(srcdir)/pkg_depends.h \
+ $(srcdir)/pkg_dest.h \
+ $(srcdir)/pkg_dest_list.h \
+ $(srcdir)/pkg_extract.h \
+ $(srcdir)/pkg_hash.h \
+ $(srcdir)/pkg_parse.h \
+ $(srcdir)/pkg_src.h \
+ $(srcdir)/pkg_src_list.h \
+ $(srcdir)/pkg_vec.h \
+ $(srcdir)/release.h \
+ $(srcdir)/release_parse.h \
+ $(srcdir)/sha256.h \
+ $(srcdir)/sprintf_alloc.h \
+ $(srcdir)/str_list.h \
+ $(srcdir)/void_list.h \
+ $(srcdir)/xregex.h \
+ $(srcdir)/xsystem.h
opkg_libcore_sources = \
opkg.c opkg.h \