summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c108f3..579a105 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,17 @@ if test "x$want_sha256" = "xyes"; then
fi
AM_CONDITIONAL(HAVE_SHA256, test "x$want_sha256" = "xyes")
+# check for openssl
+AC_ARG_ENABLE(openssl,
+ AC_HELP_STRING([--enable-openssl], [Enable signature checking with OpenSSL
+ [[default=no]] ]),
+ [want_openssl="$enableval"], [want_openssl="no"])
+
+if test "x$want_openssl" = "xyes"; then
+ PKG_CHECK_MODULES(OPENSSL, openssl)
+ AC_DEFINE(HAVE_OPENSSL, 1, [Define if you want OpenSSL support])
+fi
+
dnl **********
dnl GPGME
@@ -171,6 +182,18 @@ if test x$opkgetcdir = x; then
fi
+dnl Some special cases for the wow64 build
+if test "x$want_gpgme" = "xyes"
+then
+ if test "x$want_openssl" = "xyes"
+ then
+ AC_MSG_ERROR([--enable-gpg and --enable-openssl are mutually exclusive.
+Use --disable-gpg if you want OpenSSL smime signatures])
+ fi
+fi
+
+
+
AC_SUBST(opkglibdir)
AC_SUBST(opkgetcdir)