summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7c7831..3a40004 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,6 +243,22 @@ if test x$opkgetcdir = x; then
opkgetcdir=/etc
fi
+opkglockfile=
+AC_ARG_WITH(opkglockfile,
+[ --with-opkglockfile=FILE specifies the file used to make sure there is only
+ one instance of opkg runnning.
+ Defaults to ${opkglibdir}/opkg/lock, i.e.
+ /usr/lib/opkg/lock ],
+[case "${withval}" in
+yes) AC_MSG_ERROR(bad value ${withval} given for opkg lock file ) ;;
+no) ;;
+*) opkglockfile=$with_opkglockfile ;;
+esac])
+
+# Default if empty
+if test x$opkglockfile = x; then
+ opkglockfile=${opkglibdir}/opkg/lock
+fi
dnl Some special cases for the wow64 build
if test "x$want_gpgme" = "xyes"
@@ -258,6 +274,7 @@ fi
AC_SUBST(opkglibdir)
AC_SUBST(opkgetcdir)
+AC_SUBST(opkglockfile)
# Setup output beautifier.
SHAVE_INIT([shave], [enable])