summaryrefslogtreecommitdiffstats
path: root/libopkg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libopkg/Makefile.am')
-rw-r--r--libopkg/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
index 0e9d3a9..28fdeb9 100644
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -30,6 +30,10 @@ opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c
sprintf_alloc.c sprintf_alloc.h str_util.c str_util.h \
xregex.c xregex.h xsystem.c xsystem.h
+if HAVE_SHA256
+opkg_util_sources += sha256.c sha256.h
+endif
+
lib_LTLIBRARIES = libopkg.la
libopkg_la_SOURCES = \
$(opkg_libcore_sources) \