summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-07-17 00:56:27 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-07-17 00:56:27 (EDT)
commitdd32b60780af568ce2149aad4eecdbe7864f5c67 (patch)
tree282df9c947acb2a55f44123b54e85b3089770eca /configure.ac
parent6b5ca01869aa11436e7bae37683db2a627ef7504 (diff)
gettextize-ize
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f63e1e3..d4986b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,12 @@ AM_SILENT_RULES([yes])
AM_CONDITIONAL([IN_GIT],
[test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+GETTEXT_PACKAGE="${PACKAGE}"
+AC_SUBST([GETTEXT_PACKAGE])
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["${GETTEXT_PACKAGE}"],
+ [Define the gettext package to be used.])
+AM_GNU_GETTEXT([external])
+
AC_PROG_CC()
AM_PROG_CC_C_O()
@@ -88,6 +94,6 @@ PKG_CHECK_MODULES([LIBPNG], [libpng])
LIBPNG_CFLAGS="$(printf ' %s' "${LIBPNG_CFLAGS}" | \
sed 's/ -I/ -isystem/g;')"
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()