summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-12-23 00:10:34 (EST)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-12-23 00:10:34 (EST)
commit1e02ca70a08fb20ecf2df1cee4f6d12d0341febd (patch)
tree3759bf91affc98163a11c43d230cfcb4ade6deb8 /Makefile.am
parentc95a234cc8a903688e3902e230cda599baeb7167 (diff)
Makefile.am: Move do_subst
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 340422d..c507fab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,13 @@ libopkbuild_shsoversion = .1
man1_MANS = $(man1_sources:.1in=.1)
man3_MANS = $(man3_sources:.3in=.3)
+do_subst = sed \
+ -e 's|@[@]PACKAGE_NAME[@]@|$(PACKAGE_NAME)|g' \
+ -e 's|@[@]PACKAGE_VERSION[@]@|$(PACKAGE_VERSION)|g' \
+ -e 's|@[@]PACKAGE_DESCRIPTION[@]@|$(MANUAL)|g'
+
locale_MESSAGES = $(locale_sources:.sh=.ms)
+
dist_pkgdata_DATA = optstring
CLEANFILES = \
@@ -80,11 +86,6 @@ EXTRA_DIST = \
$(tests_data) \
tests/common.sh
-do_subst = sed \
- -e 's|@[@]PACKAGE_NAME[@]@|$(PACKAGE_NAME)|g' \
- -e 's|@[@]PACKAGE_VERSION[@]@|$(PACKAGE_VERSION)|g' \
- -e 's|@[@]PACKAGE_DESCRIPTION[@]@|$(MANUAL)|g'
-
all-local: $(locale_MESSAGES)
install-data-local: $(locale_MESSAGES)