summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-12-22 14:23:09 (EST)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-12-22 14:23:09 (EST)
commit2995916b273173942ac3846919019987b40698c8 (patch)
treeb0e5b836575f2b26f29fc640d5f523f03c1a0c8c /Makefile.am
parentff51d4b0937617d791b1460f8fa0d94b7decd393 (diff)
Makefile.am: Fix srcdir macros in test target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ff9ee39..76d8f2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,10 +131,10 @@ dist-hook:
fi
test:
- @cd '$(srcdir)/tests'; \
+ @cd '$(abs_top_srcdir)/tests'; \
all=0; failed=0; \
for test in $(tests); do \
- out="$$($(sh) "$(srcdir)/$${test}" 2>&1)"; \
+ out="$$($(SH) "$(abs_top_srcdir)/$${test}" 2>&1)"; \
if [ $${?} -eq 0 ]; then \
printf 'PASS: %s\n' "$${test}"; \
else \