summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-03-11 19:30:54 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-03-11 19:30:54 (EDT)
commit2b4a5d1df8e567a8b73f90563af05871ad6a1bb9 (patch)
tree57d1f7f3039e26edd9d75ee8028df6b733803fe0 /Makefile.am
parent0e9ca897ac4902a616ae5c33e86f345e0df33f09 (diff)
Makefile.am, lib/local.mk: Extract TODO comments from libopkbuild sources
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a137b49..4f98bf0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,6 +57,7 @@ libdatadir = $(datadir)/sh
helperdir = $(pkgdatadir)/helpers
CLEANFILES =
+extra_sources =
EXTRA_DIST = \
NEWS.opkhelper \
TODO \
@@ -89,7 +90,7 @@ todo:
printf '\n'; \
printf 'Code comments:\n'; \
printf '==============\n\n'; \
- for f in $$(printf '%s\n' $(SOURCES) | sort -u); do \
+ for f in $$(printf '%s\n' $(SOURCES) $(extra_sources) | sort -u); do \
printed=false; \
sed '=' "$(top_srcdir)/$${f}" | sed 'N; s/\n/ ./' | sed -n \
'$(todo_code_script)' | while read -r lineno line; do \