summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-12-27 14:15:36 (EST)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-12-27 14:15:36 (EST)
commit36e8c26bb0e20df9bd53c5fc9f176ac0aa2fe930 (patch)
treedac1ee3b89f6f87f837c98872e6ddb3a4b4bde72 /Makefile.am
parentbef652af4c12d0c9fef0c2a30440898fc5438c59 (diff)
Makefile.am: Trim headings and copyright section from TODO
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 387293a..9a68346 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,14 @@ todo_script = \
/^[0-9]* .[ \t]*\#[ \t]*XXX/,/^[0-9]* \.[ \t]*[^ \t\#]/{ \
/^[0-9]* \.[ \t]*\#/p; \
};
+todo_file_script = \
+ H; \
+ $${ \
+ g; \
+ s/^\n*[^\n][^\n]*\n[=-][=-]*\n\n*//; \
+ s/\n*[^\n][^\n]*\n[=-][=-]*\n.*$$//; \
+ p; \
+ };
todo:
@set -e; \
printf '\n'; \
@@ -137,7 +145,7 @@ todo:
if [ -f '$(top_srcdir)/TODO' ]; then \
printf 'TODO file:\n'; \
printf '==========\n\n'; \
- cat '$(top_srcdir)/TODO'; \
+ sed -n '$(todo_file_script)' '$(top_srcdir)/TODO'; \
printf '\n'; \
fi