summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-12-22 00:32:04 (EST)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-12-22 00:32:04 (EST)
commit510d76b6c87c4779a60519a94a5b0938809c1cb7 (patch)
tree05a6e66d96604cbed222beac0b058f004dfd5719 /Makefile.am
parent4ff14be6da04e6a5c9e09dc74d2def000837356d (diff)
libopkbuild: Use shpp
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d90e4e..8d38943 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,13 @@ include $(top_srcdir)/tests/local.mk
MANUAL = Distribution Build System
+SHPPFLAGS = \
+ -DPKGLIBDIR="$(pkgdatadir)" \
+ -DDATADIR="$(datadir)" \
+ -DLOCALEDIR="$(localedir)" \
+ -DSYSCONFDIR="$(sysconfdir)" \
+ -DMETADATA="$(METADATA)"
+
bin_SCRIPTS = $(bin_sources:.sh=)
pkgdata_SCRIPTS = $(pkgdata_sources:.sh=.sm)
pkgdatapackage_SCRIPTS = $(pkgdatapackage_sources:.sh=.sm)
@@ -162,7 +169,8 @@ test:
.sh.sm:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"
- $(AM_V_at)$(do_subst) $< >$@
+ $(AM_V_at)$(SH) -n $<
+ $(AM_V_at)'$(srcdir)/tools/shpp.sh' $(SHPPFLAGS) $< $@
.1in.1:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"