summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2018-12-27 12:18:47 (EST)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2018-12-27 12:18:47 (EST)
commit8be35c3ba143befdd5f2cd048bb18d7103118fa3 (patch)
tree9e84433a54a5048737227087c112d0d986bbbdaa /Makefile.am
parentf0a2fe581c174317f4b7233843fb771bd7afa843 (diff)
Makefile.am: Fix PACKAGE_VERSION_GIT
opkbuild's tags have used "-", not "/", to separate the package name and version.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d7e6c3..1c680b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,7 @@
# along with opkbuild. If not, see <http://www.gnu.org/licenses/>.
if IN_GIT
-PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^.*/||')
+PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^[^/-]*[/-]||')
else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif