summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2023-09-25 09:17:18 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2023-09-25 09:25:20 (EDT)
commitaf90456043bb2e8a0de9e4fc70e82f4e2ff4b4c0 (patch)
tree0057c71da306ed83c7eb40377850223cdfccace3 /Makefile.am
parentcc09f4e32bb45efb247198cdb7519b8df5e92c50 (diff)
Makefile.am: Automake broke the test suite summary
Because of this in our Makefile.am: PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^[^/-]*[/-]||') PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION_GIT) and this in Automake lib/am/check.am since version 1.16.3: AM_TESTSUITE_SUMMARY_HEADER = ' for $(PACKAGE_STRING)' the test suite summary header came out like this: ============================================================================ /bin/bash: line 64: ^[^/-]*[/-]: No such file or directory /bin/bash: line 64: $')\E[m': command not found ============================================================================ but is now fixed to look like this: ============================================================================ Testsuite summary for opkbuild 4.2.2-3-gcc09f4e-dirty ============================================================================
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3cbf383..f3dbfbc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,10 @@ endif
# * Our release target
PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION_GIT)
+# Automake lib/am/check.am since version 1.16.3 defines this with single quotes,
+# which breaks PACKAGE_VERSION_GIT above.
+AM_TESTSUITE_SUMMARY_HEADER = " for $(PACKAGE_STRING)"
+
SUFFIXES = .sh .sho
SHOBJEXT = sho