summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-03-22 16:34:13 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-03-22 16:34:13 (EDT)
commitb05cff0f54674dbd9bef02fb24ee586c574d827d (patch)
tree6c34a641f9ff938313b59d6f8c5f87a492cb8715 /Makefile.am
parentf242709d0dcf17e7e042c7406cd8bb55bc42ebfe (diff)
Makefile.am: Set signing key
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d792124..8bf94c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,8 @@
# You should have received a copy of the GNU General Public License
# along with opkbuild. If not, see <http://www.gnu.org/licenses/>.
+KEY='2250 31F0 47FF E516 63ED 516F 1A45 9ECD E4D6 04BE'
+
if IN_GIT
PACKAGE_VERSION_GIT = $$(git describe --tags --dirty | sed 's|^[^/-]*[/-]||')
else
@@ -142,7 +144,7 @@ release:
set -e; \
sigs=''; \
for f in $(DIST_ARCHIVES); do \
- gpg --armor --sign $${f}; \
+ gpg --local-user $(KEY) --armor --sign $${f}; \
sigs="$${sigs} $${f}.asc"; \
done; \
ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE); \