summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-06-18 01:42:55 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-06-18 01:44:22 (EDT)
commit52e59203144ddb2864316f14695d5207d2f8de3e (patch)
tree452f963de4ee12c4cd3a473853213481bdf9082d /configure.ac
parentbb7577992d59034b95779bc234156703ec38fa3e (diff)
configure.ac, config.sh.in: Find gzip
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e6c83cd..9b55cf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,32 @@ else
fi
AC_ARG_WITH(
+ [gzip],
+ [AS_HELP_STRING([--with-gzip=PATH], [path to gzip utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-gzip requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([gzip is required])
+ ;;
+ *)
+ GZIP="${withval}"
+ AC_SUBST([GZIP])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([GZIP], [gzip])
+ if test -z "${GZIP}"; then
+ AC_MSG_ERROR([gzip not found])
+ fi
+ ]
+)
+
+AC_ARG_WITH(
[metadata],
[AS_HELP_STRING([--with-metadata=SYSTEM],
[use SYSTEM metadata plugin @<:@default: proteanos@:>@])],