summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-06-16 17:06:39 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-06-16 17:06:39 (EDT)
commita667eb02e6899ae6bba3802e38af604af1e3bac6 (patch)
treee1ec6266651d8fee7e209d541d28d72c5a4f1282 /configure.ac
parent6c5cefe56abe06b53c6c89df5de7117d53b2952c (diff)
configure.ac, config.sh.in: Check whether touch accepts -h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f733cae..1aed897 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,46 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
+ [touch],
+ [AS_HELP_STRING([--with-touch=PATH], [path to touch utility])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-touch requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([touch is required])
+ ;;
+ *)
+ OPKG="${withval}"
+ AC_SUBST([OPKG])
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([TOUCH], [touch])
+ if test -z "${TOUCH}"; then
+ AC_MSG_ERROR([touch not found])
+ fi
+ ]
+)
+AC_MSG_CHECKING([whether touch accepts -h])
+ln -s conftest.none conftest.link
+if "${TOUCH}" -h conftest.link 1>/dev/null 2>&1; then
+ if test -f conftest.none; then
+ AC_MSG_RESULT([no])
+ AC_SUBST([HAVE_TOUCH_NODEREF], [false])
+ else
+ AC_MSG_RESULT([yes])
+ AC_SUBST([HAVE_TOUCH_NODEREF], [true])
+ fi
+else
+ AC_MSG_RESULT([no])
+ AC_SUBST([HAVE_TOUCH_NODEREF], [false])
+fi
+
+AC_ARG_WITH(
[metadata],
[AS_HELP_STRING([--with-metadata=SYSTEM],
[use SYSTEM metadata plugin @<:@default: proteanos@:>@])],