summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ff9ee39..76d8f2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,10 +131,10 @@ dist-hook:
fi
test:
- @cd '$(srcdir)/tests'; \
+ @cd '$(abs_top_srcdir)/tests'; \
all=0; failed=0; \
for test in $(tests); do \
- out="$$($(sh) "$(srcdir)/$${test}" 2>&1)"; \
+ out="$$($(SH) "$(abs_top_srcdir)/$${test}" 2>&1)"; \
if [ $${?} -eq 0 ]; then \
printf 'PASS: %s\n' "$${test}"; \
else \