summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c77257d..6acc869 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,8 +47,10 @@ SHPPFLAGS = \
-DHELPERDIR="$(helperdir)" \
-DOPKG="$(OPKG)"
SHSOEXT = shso
+SHLDFLAGS = \
+ -llibopkbuild.$(SHSOEXT).$(libopkbuild_shsoversion)
LINK = printf "PACKAGE_VERSION='%s'\n" "$(PACKAGE_VERSION_GIT)" | \
- '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@ config.sh -
+ '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@ $(SHLDFLAGS) config.sh -
LIBLINK = '$(srcdir)/tools/shld.sh' -o $@
dist_pkgdata_DATA = optstring