summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d90e4e..8d38943 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,13 @@ include $(top_srcdir)/tests/local.mk
MANUAL = Distribution Build System
+SHPPFLAGS = \
+ -DPKGLIBDIR="$(pkgdatadir)" \
+ -DDATADIR="$(datadir)" \
+ -DLOCALEDIR="$(localedir)" \
+ -DSYSCONFDIR="$(sysconfdir)" \
+ -DMETADATA="$(METADATA)"
+
bin_SCRIPTS = $(bin_sources:.sh=)
pkgdata_SCRIPTS = $(pkgdata_sources:.sh=.sm)
pkgdatapackage_SCRIPTS = $(pkgdatapackage_sources:.sh=.sm)
@@ -162,7 +169,8 @@ test:
.sh.sm:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"
- $(AM_V_at)$(do_subst) $< >$@
+ $(AM_V_at)$(SH) -n $<
+ $(AM_V_at)'$(srcdir)/tools/shpp.sh' $(SHPPFLAGS) $< $@
.1in.1:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"