summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2023-04-12 02:01:12 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2023-04-12 02:01:12 (EDT)
commit2710882a528c5e68cf8a647d5b6d3f100d52a9ff (patch)
tree8cf60c06607c8e6b88527976f8494cbd698dee7b /Makefile.am
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am103
1 files changed, 103 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9d60b35
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,103 @@
+# Process this file with automake to produce an input makefile.
+#
+# Copyright (C) 2014, 2017, 2018 Patrick McDermott
+#
+# This file is part of opkg-opk
+#
+# opkg-opk is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# opkg-opk is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with opkg-opk If not, see <http://www.gnu.org/licenses/>.
+
+KEY = '2250 31F0 47FF E516 63ED 516F 1A45 9ECD E4D6 04BE'
+
+if IN_GIT
+PACKAGE_VERSION_GIT = $$(printf ' (%s)' \
+ "$$({ git describe --tags --dirty 2>/dev/null || \
+ printf '%s-g%s' \
+ "$$(git rev-list --count HEAD)" \
+ "$$(git describe --tags --dirty --always)"; \
+ } | sed 's|^.*/||')")
+else
+PACKAGE_VERSION_GIT =
+endif
+
+# PACKAGE_STRING is used in the test suite output and log.
+# PACKAGE_VERSION can't be overridden. Automake ignores it in the IN_GIT
+# conditional (and throws a warning), and setting it to $(PACKAGE_VERSION_GIT)
+# outside the conditional causes PACKAGE_VERSION_GIT to reference itself.
+# VERSION is not set here because it is used by:
+# * Automake's distdir macro
+# * Automake's distdir target (which checks for $(VERSION) in NEWS)
+# * Our release target
+PACKAGE_STRING = $(PACKAGE_NAME) $(PACKAGE_VERSION)$(PACKAGE_VERSION_GIT)
+
+bin_PROGRAMS = opkg-opk
+
+opkg_opk_SOURCES =
+opkg_opk_CFLAGS = \
+ $(WARN_CFLAGS) \
+ $(ASAN_CFLAGS)
+opkg_opk_CPPFLAGS =
+opkg_opk_LDADD = \
+ $(ASAN_CFLAGS)
+opkg_opk_LINK = $(LINK) version.c
+EXTRA_opkg_opk_DEPENDENCIES = version.c
+CLEANFILES = version.c
+CONFIG_CLEAN_FILES =
+EXTRA_DIST = build-aux/config.rpath autogen.sh
+
+version.c: $(opkg_opk_OBJECTS) $(opkg_opk_DEPENDENCIES)
+ $(AM_V_GEN)printf 'const char *PACKAGE_VERSION_GIT = "%s";\n' \
+ "$(PACKAGE_VERSION_GIT)" >version.c
+
+really-clean: distclean
+ rm -Rf $(srcdir)/aclocal.m4 $(srcdir)/autom4te.cache/ \
+ $(srcdir)/configure \
+ $(srcdir)/config.h.in \
+ $(srcdir)/build-aux/ $(srcdir)/INSTALL $(srcdir)/Makefile.in \
+ $(srcdir)/ChangeLog
+
+dist-hook:
+if IN_GIT
+ printf 'Generated file. Do not edit.\n\n' 1>'$(distdir)/ChangeLog~'
+ GIT_DIR='$(srcdir)/.git' git log --stat --color=never \
+ 1>>'$(distdir)/ChangeLog~'
+ mv '$(distdir)/ChangeLog~' '$(distdir)/ChangeLog'
+endif
+
+release:
+ sed "s/^Released: ????-??-??\$$/Released: $$(date '+%Y-%m-%d')/" \
+ '$(srcdir)/NEWS' >'$(srcdir)/NEWS~'
+ mv '$(srcdir)/NEWS~' '$(srcdir)/NEWS'
+ $(MAKE) distcheck
+ set -e; \
+ export GIT_DIR='$(srcdir)/.git'; \
+ export GIT_WORK_TREE='$(srcdir)'; \
+ git commit -m 'NEWS: Release $(PACKAGE) $(VERSION)' -- NEWS; \
+ git tag '$(PACKAGE)/$(VERSION)' HEAD; \
+ git push --tags origin master:master
+ md5sum $(DIST_ARCHIVES) >MD5SUMS
+ sha256sum $(DIST_ARCHIVES) >SHA256SUMS
+ set -e; \
+ sigs=''; \
+ for f in $(DIST_ARCHIVES); do \
+ gpg --local-user $(KEY) --armor --detach-sign $${f}; \
+ sigs="$${sigs} $${f}.asc"; \
+ done; \
+ ssh files@files.proteanos.com mkdir -p files/pub/$(PACKAGE); \
+ rsync -az --progress --stats $(DIST_ARCHIVES) $${sigs} \
+ MD5SUMS SHA256SUMS \
+ files@files.proteanos.com:files/pub/$(PACKAGE)/$(VERSION)/
+ '$(srcdir)/scripts/announce-release.sh' \
+ $(PACKAGE) $(VERSION) '$(PACKAGE_NAME)'
+
+include $(top_srcdir)/src/local.mk