summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2023-04-20 14:11:29 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2023-04-20 14:11:29 (EDT)
commit8865acffee909d1d528d30444b44dad359913c0a (patch)
tree37d411b283bcfc36c8b38dd42c5ee6f2924ec377 /Makefile.am
parent3c8577cecc0001daf53526aa790e6638c7c50a9e (diff)
parent6daf35d0b533d28c34c69e8f678ce87b970c1acb (diff)
Merge branch 'feature/i18n'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 68131cc..b2d1c4d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,7 @@ opkg_opk_CFLAGS = \
$(WARN_CFLAGS) \
$(ASAN_CFLAGS)
opkg_opk_CPPFLAGS = \
+ -DLOCALEDIR=\"$(localedir)\" \
$(ZLIB_CFLAGS)
opkg_opk_LDADD = \
$(ASAN_CFLAGS) \
@@ -55,7 +56,7 @@ opkg_opk_LINK = $(LINK) version.c
EXTRA_opkg_opk_DEPENDENCIES = version.c
CLEANFILES = version.c
CONFIG_CLEAN_FILES =
-EXTRA_DIST = autogen.sh
+EXTRA_DIST = build-aux/config.rpath autogen.sh
version.c: $(opkg_opk_OBJECTS) $(opkg_opk_DEPENDENCIES)
$(AM_V_GEN)printf 'const char *PACKAGE_VERSION_GIT = "%s";\n' \
@@ -103,3 +104,5 @@ release:
$(PACKAGE) $(VERSION) '$(PACKAGE_NAME)'
include $(top_srcdir)/src/local.mk
+
+SUBDIRS = . po