summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2023-04-20 12:55:50 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2023-04-20 13:16:45 (EDT)
commitf7ee773acd0b9e2bec95992d238cc479cd75497a (patch)
treec03fd031a23e69fb3ec09d090ec36104ae521f78 /configure.ac
parent3c8577cecc0001daf53526aa790e6638c7c50a9e (diff)
build: gettextize
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3c0924b..f600715 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,12 @@ AM_SILENT_RULES([yes])
AM_CONDITIONAL([IN_GIT],
[test -d "${srcdir}/.git" && command -v git >/dev/null 2>&1])
+GETTEXT_PACKAGE="${PACKAGE}"
+AC_SUBST([GETTEXT_PACKAGE])
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["${GETTEXT_PACKAGE}"],
+ [Define the gettext package to be used.])
+AM_GNU_GETTEXT([external])
+
save_CFLAGS="${CFLAGS-}"
AC_PROG_CC()
AM_PROG_CC_C_O()
@@ -106,6 +112,6 @@ if test "x${address_sanitization}" = 'xyes'; then
AC_SUBST([ASAN_CFLAGS])
fi
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()