summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77d9c6a..ad067cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,6 +144,28 @@ if test "x${address_sanitization}" = 'xyes'; then
AC_SUBST([ASAN_CFLAGS])
fi
+helpersdir='${libexecdir}/${PACKAGE_TARNAME}'
+AC_ARG_WITH([helpers-dir],
+ [AS_HELP_STRING([--with-helpers-dir=DIR],
+ [helper utilities @<:@LIBEXECDIR/opkg-opk@:>@])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-helpers-dir requires $(: \
+ )an argument])
+ ;;
+ 'no')
+ helpersdir=''
+ ;;
+ *)
+ helpersdir="\"${withval}\""
+ ;;
+ esac
+ ]
+)
+AM_CONDITIONAL([WITH_HELPERS], [test -n "${helpersdir}"])
+AC_SUBST([helpersdir])
+
AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_CONFIG_HEADERS([config.h])
AC_OUTPUT()