summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 687629e..32061bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,9 @@ AC_CHECK_FUNCS([getopt_long], [],
if ${funcs_missing}; then
AC_MSG_ERROR([required functions are missing])
fi
+AC_CHECK_DECLS([[major(dev_t)], [minor(dev_t)]], [],
+ [AC_MSG_ERROR([required macros are missing])],
+ [#include <sys/sysmacros.h>])
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES([ZLIB], [zlib])