summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2019-03-22 12:34:11 (EDT)
committer P. J. McDermott <pj@pehjota.net>2019-03-22 12:34:11 (EDT)
commit267c3778366d1eb1b533c0472894a6ccf4dc5409 (patch)
tree402488e51d6a4752370705948b1fc510f3ca9b1e /configure.ac
parent163d69d0939cd7258e33a6f6d94887b01709a236 (diff)
configure.ac, Makefile.am: Find readelf instead of ldd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 9c9d038..0beab1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,25 +50,25 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
- [ldd],
- [AS_HELP_STRING([--with-ldd=PATH], [path to ldd])],
+ [readelf],
+ [AS_HELP_STRING([--with-readelf=PATH], [path to readelf])],
[
case "${withval}" in
'yes'|'')
- AC_MSG_ERROR([--with-ldd requires an argument])
+ AC_MSG_ERROR([--with-readelf requires an argument])
;;
'no')
- AC_MSG_ERROR([ldd is required])
+ AC_MSG_ERROR([readelf is required])
;;
*)
- LDD="${withval}"
+ READELF="${withval}"
;;
esac
],
[
- AC_PATH_PROG([LDD], [ldd])
- if test -z "${LDD}"; then
- AC_MSG_ERROR([ldd not found])
+ AC_PATH_PROG([READELF], [readelf])
+ if test -z "${READELF}"; then
+ AC_MSG_ERROR([readelf not found])
fi
]
)
@@ -143,7 +143,7 @@ AC_ARG_WITH(
)
AC_SUBST([SH])
-AC_SUBST([LDD])
+AC_SUBST([READELF])
AC_SUBST([OPKG])
AC_SUBST([multiarch_libdir])
AC_SUBST([helperdir])