summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2019-03-21 19:06:33 (EDT)
committer P. J. McDermott <pj@pehjota.net>2019-03-21 19:06:33 (EDT)
commit67e43afdaa931250b2628a465bae116f20346550 (patch)
treeca7dd1a190b40d65fec53d3d3d320a832303f9e9 /configure.ac
parent2a4197d006e434a067b0e9e73bc21f31a61afe5f (diff)
configure.ac: Find opkg
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 311213e..9c9d038 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,30 @@ AC_ARG_WITH(
]
)
+AC_ARG_WITH(
+ [opkg],
+ [AS_HELP_STRING([--with-opkg=PATH], [path to opkg])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-opkg requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([opkg is required])
+ ;;
+ *)
+ OPKG="${withval}"
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([OPKG], [opkg])
+ if test -z "${OPKG}"; then
+ AC_MSG_ERROR([opkg not found])
+ fi
+ ]
+)
+
AC_ARG_ENABLE(
[multiarch-libdir],
[AS_HELP_STRING(
@@ -120,6 +144,7 @@ AC_ARG_WITH(
AC_SUBST([SH])
AC_SUBST([LDD])
+AC_SUBST([OPKG])
AC_SUBST([multiarch_libdir])
AC_SUBST([helperdir])
AC_CONFIG_FILES([Makefile])