summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2014-02-27 19:09:31 (EST)
committer P. J. McDermott <pjm@nac.net>2014-02-27 19:09:31 (EST)
commit8b2b5b277d2225aabcc691bdcefe58f21382ec7f (patch)
treee4787f36b77861e47c5f635f9dc3891cf9a7c2c4 /configure.ac
parentb732112c8e1b99ade1c89fa51ec1683fae05b21c (diff)
Switch to using GNU Autoconf and Automake.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac74
1 files changed, 74 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a736956
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,74 @@
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright (C) 2013, 2014 Patrick "P. J." McDermott
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_INIT([OPK Build Helper Tools], [3.0.0-beta4],
+ [mailto:proteanos-dev@lists.proteanos.com], [opkhelper],
+ [http://www.proteanos.com/dev/opkhelper/])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_SRCDIR([src/oh-installfiles.sh])
+
+AM_INIT_AUTOMAKE([foreign dist-bzip2 dist-xz subdir-objects])
+
+AC_ARG_WITH(
+ [sh],
+ [AS_HELP_STRING([--with-sh], [POSIX-conformant shell with `local'])],
+ dnl This `dnl' is needed to workaround Vim syntax highlighting.
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR([--with-sh requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([sh is required])
+ ;;
+ *)
+ SH="${withval}"
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([SH], [sh])
+ if test -z "${SH}"; then
+ AC_MSG_ERROR([sh not found])
+ fi
+ ]
+)
+
+AC_ARG_ENABLE(
+ [multiarch-libdir],
+ [AS_HELP_STRING(
+ [--disable-multiarch-libdir],
+ [do not use multiarch library paths in packages]
+ )],
+ [
+ opt='multiarch-libdir'
+ case "${enableval}" in
+ 'yes'|'no') ;;
+ *) AC_MSG_ERROR(
+ [bad value ${enableval} for ${opt} option]) ;;
+ esac
+ multiarch_libdir="${enableval}"
+ ],
+ [
+ multiarch_libdir='yes'
+ ]
+)
+
+AC_SUBST([SH])
+AC_SUBST([multiarch_libdir])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT()