summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 57af8a2..8a55037 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,15 @@ AC_ARG_WITH(
[AS_HELP_STRING([--with-opkbuild-helpers=PATH],
[specify directory to install opkbuild helper script])],
[
- helperdir="${withval}"
+ case "${withval}" in
+ 'yes'|'')
+ helperdir='$(datadir)/opkbuild/helpers'
+ ;;
+ 'no')
+ helperdir=''
+ ;;
+ *)
+ helperdir="${withval}"
],
[
helperdir='$(datadir)/opkbuild/helpers'
@@ -84,5 +92,6 @@ AC_ARG_WITH(
AC_SUBST([SH])
AC_SUBST([multiarch_libdir])
AC_SUBST([helperdir])
+AM_CONDITIONAL([HELPER], [test "x${helperdir}" != 'x'])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT()