summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8a55037..8f4c040 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,15 +74,19 @@ AC_ARG_WITH(
[AS_HELP_STRING([--with-opkbuild-helpers=PATH],
[specify directory to install opkbuild helper script])],
[
+ opt='opkbuild-helpers'
case "${withval}" in
'yes'|'')
- helperdir='$(datadir)/opkbuild/helpers'
+ AC_MSG_ERROR(
+ [--with-${opt} requires an argument])
;;
'no')
- helperdir=''
+ AC_MSG_ERROR([${opt} is required])
;;
*)
helperdir="${withval}"
+ ;;
+ esac
],
[
helperdir='$(datadir)/opkbuild/helpers'
@@ -92,6 +96,5 @@ AC_ARG_WITH(
AC_SUBST([SH])
AC_SUBST([multiarch_libdir])
AC_SUBST([helperdir])
-AM_CONDITIONAL([HELPER], [test "x${helperdir}" != 'x'])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT()