summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1d0966..882f920 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,31 @@ AC_ARG_WITH(
]
)
+AC_ARG_WITH(
+ [ldconfig],
+ [AS_HELP_STRING([--with-ldconfig=PATH], [path to ldconfig])],
+ [
+ case "${withval}" in
+ 'yes'|'')
+ AC_MSG_ERROR(
+ [--with-ldconfig requires an argument])
+ ;;
+ 'no')
+ AC_MSG_ERROR([ldconfig is required])
+ ;;
+ *)
+ LDCONFIG="${withval}"
+ ;;
+ esac
+ ],
+ [
+ AC_PATH_PROG([LDCONFIG], [ldconfig])
+ if test -z "${LDCONFIG}"; then
+ AC_MSG_ERROR([ldconfig not found])
+ fi
+ ]
+)
+
AC_ARG_ENABLE(
[multiarch-libdir],
[AS_HELP_STRING(