summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pjm@nac.net>2012-02-09 10:56:43 (EST)
committer P. J. McDermott <pjm@nac.net>2012-02-09 10:56:43 (EST)
commitf431cd1a48a6a5186633bf5f16a2d21cb4399e8c (patch)
tree337e36fd9d7884fcf76ba769ab7b0039f52d9d31 /src/Makefile.am
Initial commit.
TODO: Copyright information. Including source code and a patch to add files generated by GNU Autoconf is not very pretty... Running 'make dist' in the SVN trunk to generate a source archive might be better.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..26f2d99
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,37 @@
+ACLOCAL_AMFLAGS = -I shave
+
+SUBDIRS = libbb libopkg src tests utils man
+
+
+HOST_CPU=@host_cpu@
+BUILD_CPU=@build_cpu@
+OPKGLIBDIR=@opkglibdir@
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\"
+
+PATHFINDER_CFLAGS = @PATHFINDER_CFLAGS@
+PATHFINDER_LIBS = @PATHFINDER_LIBS@
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libopkg.pc
+
+
+
+interceptdir = $(datadir)/opkg/intercept
+intercept_DATA = intercept/ldconfig intercept/depmod intercept/update-modules
+
+install-data-hook:
+ chmod +x $(DESTDIR)$(datadir)/opkg/intercept/*
+
+EXTRA_DIST = $(intercept_DATA)
+
+MAINTAINERCLEANFILES= \
+ configure \
+ Makefile.in \
+ config.guess \
+ config.sub \
+ ltmain.sh \
+ .Makefile.am.swp \
+ aclocal.m4
+
+package: all-recursive
+ STRIPPROG=$(STRIP) INSTALL=$$PWD/install-sh binary-arch