summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2020-06-29 01:34:28 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2020-06-29 01:42:50 (EDT)
commiteb7b301625bd8319b45ec47dce2462c06ac4050d (patch)
tree7c4e21b9da7e875163d0f03c7569169ff1760d90
parent3cf141329dbc07ba247d0a5c9d2ab19da41658a1 (diff)
Add patch to fix usign errors on empty indices
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0001-update_feeds-Fix-usign-errors-on-empty-indices.patch29
-rw-r--r--debian/patches/series1
3 files changed, 37 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4a04a91..a327358 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+pro-archman (2.1.0-2) UNRELEASED; urgency=medium
+
+ * Backport a patch from upstream to fix a failure to sign empty feed
+ index files.
+
+ -- Patrick McDermott <patrick.mcdermott@libiquity.com> Mon, 29 Jun 2020 01:33:21 -0400
+
pro-archman (2.1.0-1) unstable; urgency=medium
* New upstream version.
diff --git a/debian/patches/0001-update_feeds-Fix-usign-errors-on-empty-indices.patch b/debian/patches/0001-update_feeds-Fix-usign-errors-on-empty-indices.patch
new file mode 100644
index 0000000..41a6a41
--- /dev/null
+++ b/debian/patches/0001-update_feeds-Fix-usign-errors-on-empty-indices.patch
@@ -0,0 +1,29 @@
+From 5285baf194c84bac30d49cc8e8d42e70a3a1a43f Mon Sep 17 00:00:00 2001
+From: Patrick McDermott <patrick.mcdermott@libiquity.com>
+Date: Mon, 29 Jun 2020 01:30:37 -0400
+Subject: [PATCH] update_feeds(): Fix usign errors on empty indices
+
+Fixes:
+
+ Cannot open message file: Invalid argument
+---
+ src/index.sh | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/index.sh b/src/index.sh
+index 275934e..6e77a9d 100644
+--- a/src/index.sh
++++ b/src/index.sh
+@@ -201,7 +201,8 @@ update_feeds()
+ mv -- "${sect}/Packages~" \
+ "${sect}/Packages"
+ else
+- 1>"${sect}/Packages"
++ # Must be non-empty for usign to work.
++ printf '\n' 1>"${sect}/Packages"
+ fi
+ if ${conf_gzip}; then
+ "${GZIP}" -9c -- "${sect}/Packages" \
+--
+2.11.0
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..f9ee640
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-update_feeds-Fix-usign-errors-on-empty-indices.patch