summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9b040d7..c61818f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,3 +8,21 @@
override_dh_auto_configure:
dh_auto_configure -- --libdir=/usr/share
+
+get-orig-source:
+ uscan --noconf --verbose --rename --force-download \
+ --download-current-version
+
+unpack-orig-source:
+ for f in *; do \
+ if [ -e $${f} ] && [ $${f} != debian ]; then \
+ rm -Rf $${f}; \
+ fi; \
+ done
+ set -e; \
+ source=$$(dpkg-parsechangelog | sed -n 's/^Source: //p'); \
+ version=$$(dpkg-parsechangelog | \
+ sed -n 's/^Version: \([^-]*\).*$$/\1/p'); \
+ tar -xJf ../$${source}_$${version}.orig.tar.xz; \
+ mv $${source}-$${version}/* .; \
+ rmdir $${source}-$${version}/