summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 14:36:36 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 14:36:36 (EDT)
commit7147d455fe5f70abb1a078a76a3c471d3d015d05 (patch)
treea5b6d8e6718ef38c765dc090e3e762fbd8f44941 /Makefile.am
parent90273a6500217206d98b47dc911464306ffdb125 (diff)
Makefile.am: Preprocess scripts with shpp
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 69d83de..bf7182a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,9 @@ LINK = printf "PACKAGE_VERSION='%s'\n" "$(PACKAGE_VERSION_GIT)" | \
bin_PROGRAMS = pro-archman
pro_archman_SOURCES =
+pro_archman_SHPPFLAGS = \
+ -DLOCALEDIR="$(localedir)" \
+ -DTEXTDOMAIN="$(TEXTDOMAIN)"
pro_archman_LDADD = $(pro_archman_SOURCES:.sh=.sho)
EXTRA_pro_archman_DEPENDENCIES = config.sh
@@ -107,7 +110,8 @@ dist-hook:
.sh.sho:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"
- $(AM_V_at)$(do_subst) $< >$@
+ $(AM_V_at)$(SH) -n $<
+ $(AM_V_at)'$(srcdir)/tools/shpp.sh' $(prokit_SHPPFLAGS) $< $@
.sh.ms:
$(AM_V_GEN)$(MKDIR_P) "$$(dirname $@)"