summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorP. J. McDermott <pj@pehjota.net>2017-07-22 12:19:17 (EDT)
committer P. J. McDermott <pj@pehjota.net>2017-07-22 12:19:17 (EDT)
commitbaa8bb489ea627364f546b20bfc4bdcbcbe00306 (patch)
treee3812dca86464f849d1a5a7237e2106185efe10b /Makefile.am
parent44938092a4aae34e9c7ddfc038685a342c4ec4fc (diff)
Makefile.am: Link pro-archman
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ab98350..ec5b51f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,20 @@ else
PACKAGE_VERSION_GIT = $(PACKAGE_VERSION)
endif
+# This PACKAGE_VERSION stuff is a rather gross hack, but it's the only reliable
+# way to put Git commit information in the prokit executable. Setting
+# PACKAGE_VERSION in configure causes it to become outdated until the next
+# configure run. Adding it to the preprocessor command line can cause multiple
+# values of it to exist in the linked executable.
+LINK = printf "PACKAGE_VERSION='%s'\n" "$(PACKAGE_VERSION_GIT)" | \
+ '$(srcdir)/tools/shld.sh' -I '$(SH)' -o $@ config.sh -
+
+bin_PROGRAMS = pro-archman
+
+pro_archman_SOURCES =
+pro_archman_LDADD = $(bin_sources)
+EXTRA_pro_archman_DEPENDENCIES = config.sh
+
bin_SCRIPTS = $(bin_sources:.sh=)
pkgdata_SCRIPTS = $(pkgdata_sources:.sh=.sm)
pkgdatacmd_SCRIPTS = $(pkgdatacmd_sources:.sh=.sm)