summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick McDermott <patrick.mcdermott@libiquity.com>2019-04-09 23:02:39 (EDT)
committer Patrick McDermott <patrick.mcdermott@libiquity.com>2019-04-09 23:02:39 (EDT)
commit0fd1303c60ac5d906b54ee29b244f431a8249d18 (patch)
tree046a1298b5ac5df1093e86f7ae7402859d503114 /configure.ac
parent35e6cf8b9a26e767615b773cceafb543484b75ef (diff)
configure.ac, config.sh.in: Drop check for date with %s
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index b0c026b..f486c94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,37 +164,6 @@ AC_ARG_WITH(
fi
]
)
-AC_ARG_WITH(
- [date],
- [AS_HELP_STRING([--with-date=PATH],
- [path to date utility with `%s' format specifier])],
- dnl This `dnl' is needed to workaround Vim syntax highlighting.
- [
- case "${withval}" in
- 'yes'|'')
- AC_MSG_ERROR(
- [--with-date requires an argument])
- ;;
- 'no')
- AC_MSG_ERROR([date is required])
- ;;
- *)
- DATE="${withval}"
- AC_SUBST([DATE])
- ;;
- esac
- ],
- [
- AC_PATH_PROG([DATE], [date])
- if test -z "${DATE}"; then
- AC_MSG_ERROR([date not found])
- fi
- ]
-)
-dnl Ugh, quadrigraphs.
-case "$(date '+%s' 2>/dev/null)" in *@<:@!0-9@:>@*|'')
- AC_MSG_ERROR([${DATE} doesn't support the `%s' format sequence])
-esac
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([config.sh])